®

Parallels Plesk Panel

2

Preface

Contents
Preface

3

Typographical Conventions ............................................................................................................3
Feedback ........................................................................................................................................4

Introduction

5

Getting Familiar With the Builder Editor

6

Creating a Website

8

Importing Sites from SiteBuilder 4.5 ...............................................................................................9

Editing a Website

11

Structure: Pages and Navigation .................................................................................................11
Adding and Removing Pages ............................................................................................12
Adding and Removing Navigation Links ............................................................................13
Design: Layout, Styles, Color Scheme, and Header ....................................................................14
Changing Your Website Layout .........................................................................................15
Selecting Website Colors and Font Styles .........................................................................16
Changing the Website Header Elements ...........................................................................18
Content: Text, Tables, Images, Video, Forms, and Scripts .........................................................18
Text, Tables, Hyperlinks, and Images ...............................................................................19
Embedded Video................................................................................................................23
Contact Form .....................................................................................................................23
Blog ....................................................................................................................................24
Commenting .......................................................................................................................27
Documents and Other Downloadable Files .......................................................................29
Buttons for Sharing on Social Networks ............................................................................30
Site Search.........................................................................................................................30
Online Store .......................................................................................................................31
Custom Scripts ...................................................................................................................32
Advertisement ....................................................................................................................33
Settings and Tools for Webmasters .............................................................................................33

Saving and Loading Copies of a Website

37

Publishing a Website to the Internet

39

Publishing a Website Copy to Facebook

40

Deleting a Website

42

Preface

Preface

In this section:
Typographical Conventions ............................................................................... 3
Feedback .......................................................................................................... 4

Typographical Conventions
Before you start using this guide, it is important to understand the documentation
conventions used in it.
The following kinds of formatting in the text identify special information.
Formatting convention

Type of Information

Example

Special Bold

Items you must select,
such as menu options,
command buttons, or
items in a list.

Go to the System tab.

Read the Basic Administration
Titles of chapters,
sections, and subsections. chapter.
Italics

Used to emphasize the
The system supports the so
called wildcard character search.
importance of a point, to
introduce a term or to
designate a command line
placeholder, which is to be
replaced with a real name
or value.

Monospace

The names of commands,
files, and directories.

The license file is located in the
http://docs/common/licen
ses directory.
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Formatting convention
Preformatted

Type of Information

Preformatted Bold

What you type, contrasted
with on-screen computer
output.

# cd /root/rpms/php

CAPITALS

Names of keys on the
keyboard.

SHIFT, CTRL, ALT

KEY+KEY

Key combinations for
CTRL+P, ALT+F4
which the user must press
and hold down one key
and then press another.

On-screen computer
output in your commandline sessions; source code
in XML, C++, or other
programming languages.

Example
# ls –al /files
total 14470

Feedback
If you have found an error in this guide, or if you have suggestions or ideas on how to
improve this guide, please send your feedback using the online form at
http://www.parallels.com/en/support/usersdoc/. Please include in your report the guide's title,
chapter and section titles, and the fragment of text in which you have found an error.

CHAPTER 1

Introduction
Parallels Web Presence Builder (further referred to as Builder or editor) is an easy and
intuitive means of creating websites for small businesses and individuals.
To start creating a website with Builder, you first need to select your website topic,
specify website name, and select a language. Please note that the language is
selected for your website, not for the Builder editor's interface. The Builder editor's
interface language can be changed only through Parallels Plesk Panel.
You will be prompted to provide information about yourself to prefill your website with
information. Please note that the information you provide will not be stored or used
anywhere else, it will be used only for filling your website content, such as “About Us”
and “Contact Us” pages. You can change or remove this information at any time later.
When the necessary information is provided, Builder generates a website with the
unique design. The website design consists of a number of elements. Each time
Builder generates a website design, a random set of element designs is used, so you
can be sure that the website design you receive is never repeated.

CHAPTER 2

Getting Familiar With the Builder Editor
The Builder editor's interface consists of two major parts: your website and main menu.
A website consists of a number of elements, or modules. Each module can be edited
separately. Here we will familiarize you with basic principles of website modules editing
similar for all modules.
The website modules can be of two basic types:


Simple modules. These modules appear only on one website page, such as a
simple text block.



Sitewide modules. These modules appear on all website pages, such as the
website header or navigation.

To locate a website module, hover the mouse pointer over the part of the website you
want to change. A dotted frame will appear around the module. A control panel
prompting to move, edit, or remove/hide the module will appear next to the dotted
frame.
The dotted frame around simple modules is dark grey, around sitewide modules it is
purple.
To edit a website module, click anywhere on the module. A dotted frame will appear
around the module. A context menu with module editing options will appear next to the
dotted frame.
The editor's main menu offers website editing options grouped under six tabs:


Modules. Here you can choose necessary modules and drag them to any place on
the page to fill your website with content.



Layout. Here you can select the number of sidebars on the page, width of the page,
sidebars and margins, and fixed or liquid type of layout.



Style. Here you can select base color scheme for your website, change colors of
separate elements, select fonts and styles of borders for your website.



Pages. Here you can add and delete pages, rename them, edit such page meta
information as description and keywords, mark page as hidden, so that your visitors
cannot access it from the site menu.



Documents. Here you can upload your documents, images, and other files in various
formats to your hosting account. You can then easily insert links to these
documents into your website pages. Or, you can just keep the files on the hosting
account for your own needs.



Settings. Here you can edit your website name, description and keywords for search
engines, upload a site icon (favicon), optimize ranking of your website in search
engine results, and add a copy of your site to a Facebook page.

Getting Familiar With the Builder Editor

7

From the main menu, you can also do the following:


Access Web Presence Builder Getting Started video tutorial and User’s Guide. To do this,
select the corresponding option from the Help menu.




Save and load copies of your website by using the Save and Revert options.
Publish your website by using the Publish button.



Discard any changes made to a site and start creating a site anew by selecting
More > Start Over. This does not delete your already published site copy.



Delete a current website draft from the editor by selecting More > Remove Site. This
does not delete your already published site copy.

You can drag the main menu to any place on the page for your convenience or
minimize it.
You can also access all options of the main menu in the context menu at any place on
the page. To open the context menu, click the right mouse button.

CHAPTER 3

Creating a Website
 To create a website in Builder:
1. In Control Panel, go to either the Home tab or the Websites & Domains tab,
and click Launch Web Presence Builder.
If you have only one domain name configured, the editor will open in a new browser
window or tab.

2. If you have several domain names, click the corresponding link Edit in
Web Presence Builder. The wizard will open in a new browser window or
tab.
3. Select your website topic and click Create Site.
Note: If you already have a website created with SiteBuilder 4.5 and hosted
elsewhere, at this step, you can choose the option to import your website to your
new hosting account. Learn more about it in the section Importing Sites from
SiteBuilder 4.5 (on page 9).

4. Provide information about yourself to prefill your website.
The information you provide will not be stored or used anywhere else, it will be used
only for prefilling your website content, such as “About Us” and “Contact Us” pages.
You can change or remove this information at any time later.

5. Click Submit and Create Site.
Builder takes some time to generate a website with unique design and prefilled content.

In this chapter:
Importing Sites from SiteBuilder 4.5 .................................................................. 9
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Importing Sites from SiteBuilder 4.5
If you have a site created with SiteBuilder 4.5, you can import it to Web Presence
Builder 10.4.
Note: Import of sites from earlier versions of SiteBuilder or other content management
systems is not supported.
If your site was created with an earlier version of SiteBuilder (4.4 or earlier), and you
would like to transfer your site, you can do the following:


Contact your hosting provider and ask them to upgrade your account to the latest
version of Web Presence Builder.



Transfer your site manually by copying and pasting the content.

During site import, most part of the site structure and content can be transferred
successfully. However, we cannot guarantee that all content will be transferred.
In most cases, the following elements are imported without any issues:


SiteMap.




Static pages, including links and images in text modules. Note that text blocks that
exceed 30 kilobytes may be cut; therefore, some parts of text might be missing.
Header image (if it is not a custom image).




Slogan, site title.
Logo (if it is not a custom image).



Footer text.



Meta info (keywords, description).

The rest of the modules can be imported only as text widgets with static content, links
and images. Buttons will not work. Image gallery structure can be imported without
images.

 To import a site from SiteBuilder 4.5:
1. Open the Builder editor, and on the topic selection screen, click Import
Site from SiteBuilder 4.5.
2. Type the Internet address (domain name) of the site that you want to
import. For example: http://example.com.
3. Select the checkbox to confirm that you are aware of possible import
issues and click Import Site.
4. After the site is imported, review and edit it as required (on page 11).
You can compare the imported site version with your original site and
add the missing information manually.
5. When finished with editing, publish it to your hosting account (on page
39).
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If you are publishing your new site to the same webspace where your site created with
SiteBuilder 4.5 was hosted, the old site will be overwritten.

CHAPTER 4

Editing a Website
In Builder, you can change virtually each element of your website. Simple elements are
changed in place - you open a page where the element is used, edit it and see the
result right away. Sitewide elements are changed in one place but the changes are
applied to each page of your website.
Note: If you are using Internet Explorer, we strongly recommend that you avoid using
browser zoom to change the size of text displayed in your browser window. Please
note that websites in Builder will perform and look best at normal zoom (100%).

In this chapter:
Structure: Pages and Navigation ....................................................................... 11
Design: Layout, Styles, Color Scheme, and Header .......................................... 14
Content: Text, Tables, Images, Video, Forms, and Scripts ................................ 18
Settings and Tools for Webmasters ................................................................... 33

Structure: Pages and Navigation
This section describes how to add pages to a site, set their location in the site
structure, and add navigation links.

In this section:
Adding and Removing Pages ............................................................................ 12
Adding and Removing Navigation Links ............................................................ 13
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Adding and Removing Pages
Your site can have two levels of pages nesting.

 To add a new page to your website:
1. Go to the Pages tab.
2. Click Add page. The new page appears highlighted with green.
3. Position the new page by dragging it to the right place or by using
arrows.
4. Specify the page title.
5. Specify a concise description of the page content that will be displayed
on search engines results pages and the keywords by which the page
will be found by search engines.
Note: Page name and Page link name are required fields. Description and Keywords are
optional fields. If you specify keywords for a page, they should be separated by
commas without white spaces.

6. If you want to make the page invisible for your website visitors, select
the Hidden page checkbox.
7. If you want to restrict access to the page with password authentication,
select the Protected page checkbox and specify a username and a
password.
8. Click OK to save changes.

 To change the location or properties of a page:
1. Go to the Pages tab.
2. Select the page you want to edit.
3. Change the page position by dragging it to the right place or by using
arrows.
4. Edit the page title.
5. Edit or remove a concise description of the page content that will be
displayed on search engines results pages and the keywords by which
the page will be found by search engines.
Note: Page name and Page link name are required fields. Description and Keywords are
optional fields. If you specify keywords for a page, they should be separated by
commas without white spaces.

6. If you want to make the page invisible for your website visitors, select
the Hidden page checkbox.

Editing a Website
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7. If you want to restrict access to the page with password authentication,
select the Protected page checkbox and specify a username and a
password.
8. Click OK to save changes.

 To delete a page from your website:
1. Go to the Pages tab.
2. Select the page you want to delete.
3. Click Delete page.
4. Click OK to save changes.

Adding and Removing Navigation Links
By default, a horizontal navigation bar with links to site pages is inserted below the
header of your site. It is automatically updated every time you add, change, move, or
remove pages from the site.
If you use sidebars on the site, then the horizontal bar under the header includes only
links to the first-level pages, and the sidebars show the links of the second and third
levels.
You can move navigation blocks by dragging them to other areas of the site.
For each navigation block, you can specify what levels of pages should be included in
the menu, change menu alignment (for example, show it in the middle of the page
instead of the default alignment to the left), and change the color, style, and size of the
font used for the links. To change any of these settings, place the mouse pointer over a
navigation block and click Edit.
If you occasionally remove a navigation block, you can re-insert it. To do this, go to the
Modules tab, select Navigation, and drag it to the area on the page where you want to
add it. The navigation block will be inserted into all pages of the website.
For the convenience of your site visitors, you might also want to add the breadcrumb
navigation blocks. Breadcrumb navigation is a chain of links that represents the user's
path from the site's main page to a current page. To add a breadcrumb navigation
block, go to the Modules tab, select Breadcrumbs, and drag the module to the area on the
page where you want to add it. The navigation block will be inserted into all pages of
the website.
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Design: Layout, Styles, Color Scheme,
and Header
This section describes how to change layout, color scheme, and header elements of
the site.

In this section:
Changing Your Website Layout ......................................................................... 15
Selecting Website Colors and Font Styles ......................................................... 16
Changing the Website Header Elements ........................................................... 18
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Changing Your Website Layout
A website created with Builder can have one, two, or no sidebars. On a sidebar, you
can place a navigation block, an ads block, or just a sitewide text or image.

 To select the number of sidebars on your website:
1. Go to the Layout tab.
2. Select No sidebars, 1 sidebar, or 2 sidebars.
3. To move a sidebar to another side of your website with one sidebar, or
to switch sidebars on your website with two sidebars, click Switch
sidebars.
4. Click OK to save changes.

 To select the layout type for your website:
1. Go to the Layout tab.
2. Select the layout type and specify the website width:


Fixed layout: your website will be of specific size regardless of the size of the
browser window viewing the page. In this case, specify your website width in
pixels.



Liquid layout: based on percentages of the current browser window's size. In this
case, specify your website width as a percentage of the browser window's size.

3. Click OK to save changes.

 To select the size of page elements on your website:
1. Go to the Layout tab.
2. Specify the size of vertical and horizontal margins, which is the space
between the neighbouring elements edges, in pixels.
3. For a website with one or two sidebars, select Sidebar width and specify
the width of each sidebar in pixels.
The size of the main content field will be determined automatically.

4. Select Minimal height and specify the height of each sidebar and the main
content field in pixels.
This value shows the height of your website elements without content. When you
add content to the sidebars and the main content field, they will stretch in height to
fit the content.

5. Click OK to save changes.
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Selecting Website Colors and Font Styles
General color scheme, or styleset, of your website is comprised from four colors. Each
color is used for several website elements at once. You can adjust colors of individual
elements on the Style tab > Colors tab.

 To select the general color scheme for your website:
1. Go to the Style tab > Scheme tab.
2. Select the color scheme, or styleset, of your website in the menu.
You will see the four colors composing the color scheme of your website.

3. To adjust one of the colors of your website color scheme, click the
respective color field and change the hexadecimal color code value or
select a color with the color picker.
Note: The changes of individual elements colors previously made on the Colors
subtab will be overridden by the changes made here.

4. Click OK to save changes.

 To select colors of individual website elements:
1. Go to the Style tab > Colors tab.
2. Select the website element in the menu.
3. Adjust the element's background color by clicking the background color
field and editing the hexadecimal color code value or selecting a color
with the color picker.
4. If you want to use gradient filling, select the Gradient option, and then
select the pattern from the menu.
5. For element with text, adjust font colors by clicking the respective color
field and editing the hexadecimal color code value or selecting a color
with the color picker.
Note: Modifying the styleset on the Scheme tab will override the changes made on
the Color tab.

6. Click OK to save changes.

 To select fonts for headings and body text of your website:
1. Go to the Style tab > Fonts tab.
2. For each font type, select the font face and size in the menus.
3. For headings, select the font decoration. You can use bold (the B icon)
and italics (the I icon).

Editing a Website
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Note: The settings made here define only general rules for your website fonts. You
can always adjust fonts of individual elements in place.

4. Click OK to save changes.

 To select borders for website elements:
1. Go to the Style tab > Borders tab.
2. Select the border type for elements inside your website from the Internal
containers border menu.
3. Select the elements that will have the border.
Note: You can select only one internal border type for all elements on your website,
but you can select whether this border will be used for certain elements.

4. Select the external border for your website from the External site border
menu.
5. Click OK to save changes.
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Changing the Website Header Elements
The site header consists of the following elements:


Header background image.




Logo image.
Site title.



Subtitle. This usually includes a description of your site or a company slogan.

 To change the background image or other elements of the header (logo,
title, or subtitle):
1. Click the header image.
2. Do any of the following:


To use an image from the Builder's library, select the option Selection from our
library, and then select an image from the Image list menu. To help you find an
appropriate image, select the Recommended option or type a keyword in the input
box.



To use your own image, select the option Selection from own file, click Browse, and
select the image you want to use. You should use only images in the GIF,
JPEG, and PNG formats, preferably, not wider than 900 pixels. We recommend
that you also select the Fit image size checkbox to ensure that your image fits the
site layout.



To remove an image, select the option no image and specify the height of the
header block in pixels.

3. Under Show Header Elements, select the checkboxes corresponding to the
elements that you want to show in the header.
4. If you want to remove a logo image or upload your own logo, click the
logo image.
5. If you want to change the title or subtitle, click the corresponding fields
on the header and change them as you want.
Note that you can freely move the site title within the header area.

Content: Text, Tables, Images, Video,
Forms, and Scripts
This section describes how to fill your site with content and enhance it with useful
functions provided by the editor's modules.

Editing a Website
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Text, Tables, Hyperlinks, and Images
 To add text, lists, tables, or images to a particular page:
1. Go to the Modules tab, select Text & Images, and drag the module to the
page.
2. Type text on the screen and use icons on the module's toolbar to format
the text, add tables, hyperlinks, and images.
Note: If you want to add a block with text and images to all pages of a site, go to the
Modules tab, select Sitewide Text & Images, and drag the module to the page.
The Text & Images module's toolbar provides access to the following tools and functions.
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1. Move the text and images block within the webpage.
2. Remove the block with its contents.
3. Save changes.
4. Cancel the changes made.
5. Move the toolbar.
6. Select the paragraph style and font face.
7. Select the font size.
8. Select the font style: bold, italics, underlined, and strikethrough.
9. Select the text and background colors.
10. Select text alignment: left, center, right, or justified (aligned to both the left and right
margins with added extra spaces between words).
11. Increase and decrease the indent level of the paragraph.
12. Start a numbered or bulleted list.
13. Insert a table and specify the number of rows and columns.
After you insert a table, a number of additional icons become accessible from the
toolbar. Use them to change properties of the table rows and cells, insert and
remove rows and columns, split and merge table cells.
14. Insert symbols that are not on your keyboard, such as copyright and trade mark
signs, and other Unicode symbols.
15. Insert a horizontal line.
16. Edit the HTML source code of the page.
17. Undo and redo changes.
18. Add and remove hyperlinks to the pages of your website or external resources.
Insert HTML anchors into particular sections of webpages so that you could further
link to them from other pages of your site.
19. Insert an image, adjust its size, specify an alternative text, and text wrapping.
Alternative text is shown instead of images in browsers that do not support or are
configured to not show images.
If you want to insert many pictures into a single page, consider using the Image Gallery
module instead of the Text & Images module. With Image Gallery, you can upload pictures
from your local computer or use pictures published to the Picasa Web Albums photo
sharing service.

 To add an image gallery to your site and upload pictures:
1. Go to the Modules tab, select Image Gallery, and drag the module to the
page.
2. In module settings, on the Image Storage tab, select where you want to
keep pictures:

Editing a Website



If you do not have a Picasa Web Albums account that you would like to use,
leave the Web Presence Builder option selected. All images you use on your site
will be kept on your hosting account.



If you have an account in Picasa Web Albums and want to use on your site
pictures that you store there, do the following:
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a. Select the Picasa option, click the link on the Image Storage tab to
sign in to Google, and grant access to your albums from
Builder.
b. Select the album whose pictures you want to use or click Create
Album to create a new album.
c. If you want Builder to remove images from Picasa Web Albums
when you remove them from the gallery, select the checkbox
Delete images when I remove them from gallery.
When you upload images to an image gallery through the Builder editor, they
are automatically copied to your Picasa Web Albums account. When you
remove images from the gallery, they are removed from Picasa Web Albums
only if you selected the option Delete images when I remove them from gallery.

3. (Optional step.) If you want to select the size of image thumbnails to be
shown in the image gallery, click the Gallery Properties tab and select the
size of thumbnails:


Small (95 x 75 pixels).



Normal (140 x 130 pixels). This is the default setting.



Large (170 x 170 pixels).

4. To add images to the gallery, click the text Click here to upload your images,
select the images that you want to upload and click OK.
You can select and upload multiple images at once. Only images in GIF, JPEG, and
PNG formats are supported.
We recommend that you use resized images that do not exceed 1024 x 768 pixels.
Note that there is no pagination in Image Gallery: If you add a great number of
images, the website page will take quite a long time to load.

5. To change image title and description, click the corresponding
thumbnail, click the title or description, and edit the text.
If you delete the default text entirely, it will not be shown on your published site,
however, it will still be shown when you edit the site in the Builder editor.

 To remove an image from the gallery:
Place the mouse pointer over the image thumbnail and click the icon [x].

 To remove an image gallery with all pictures:
Place the mouse pointer over the image gallery block and click Remove.
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 To insert a hyperlink or a link to e-mail address into text:
1. Select the text that you want to make a link.
2. On the Text & Images module's toolbar, click the icon

.

3. Do any of the following:


To add a link to another webpage of your site, select the option A page of this site.
In the Select page menu, select the target webpage.



To add a link to a webpage or a file located on some other site, select the option
A webpage or file on the Internet, and type the address. For example,
http://example.com.



To add a link to a document or another downloadable file that you previously
uploaded through the Document Manager (as described in Documents and
Other Downloadable Files (on page 29)), select the option A document on this site,
and select the target file.



To add a link that will open a new e-mail message with a prefilled destination email address, select the option A webpage or file on the Internet, and type
mailto:<address>. For example, mailto:postmaster@example.com.
You can also:


Predefine the message subject line. For example:
mailto:postmaster@example.com?subject=My%20Subject.



Add recipients to CC and BCC lists. For example:
mailto:postmaster@example.com?subject=My%20Subject&cc=ad
dress1@example.com&bcc=address2@example.com.



Predefine text to put in the message body. For example:
mailto:postmaster@example.com?subject=My%20Subject&body=
This%20is%20sent%20from%20your%20site!

Note: You should replace white spaces with %20.

4. In the Open link in menu, select where you want to open the target page.
You can choose to open it in the same or in a new browser window or
tab.
5. In the Title box, type the description that should appear when users
place the mouse pointer over the link.
6. Click OK.

Editing a Website
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Embedded Video
You can embed into website pages video clips located on popular video sharing sites,
such as YouTube (youtube.com), Vimeo (vimeo.com), MySpace (myspace.com), and
Dailymotion (dailymotion.com).

 To insert a video into a webpage:
1. Go to the Modules tab, select Embedded Video, and drag the module to the
page.
2. Insert a link to the video or select the option Embed code if you obtained
a code from the file sharing site, and then paste the code.
3. Click OK.

 To remove a video:
Place the mouse pointer over the video and click Remove.

Contact Form
If you want your site visitors to be able to send you messages from your site, you can
add a contact form.

 To add a contact form:
1. Go to the Modules tab, select Contact Form, and drag the module to the
page.
2. On the Settings tab, specify the following:


Recipient's e-mail address. You can specify only one e-mail address.



Message subject.



Text to be shown on the button that sends the message.

3. If you want to add, move, or remove input fields from the form, or
change their labels, click the Fields tab, and make the required changes.
4. If you want to change the default message "Your feedback was sent.
Thank you." which is shown when a message is sent, click the Reply tab
and type the new text.
5. Click OK.

 To remove a contact form:
Place the mouse pointer over the form and click Remove.
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Blog
If you want to maintain an online diary on your site, or regularly publish articles on a
subject and automatically present them in a chronological order, then you need a blog.
A blog module can be added only to the first-level pages that do not have subpages.
Within blog posts, you can use text, images, embedded videos and scripts. Each blog
post can have its distinctive page description and meta information to be used by
search engines. Note that blog posts are not listed on the Pages tab (on page 12).
To let your visitors comment on your blog posts, you need to register with Disqus, a
free third-party service that provides commenting functions for your sites and keeps all
comments.

 To add a blog to your webpage:
1. Go to the Modules tab, select Blog, and drag the module to the page.
2. In the module properties, specify the following:


Number of blog posts to show on the page.



Specify whether the site visitors will be able to leave their comments.

3. Click OK.
4. To enable commenting, click the link Click here to add a new blog post.
5. Click within the gray information box at the bottom of the blank blog
post.
6. To register with Disqus, click the Register button. A registration form will
open in a new browser window or tab.
7. Specify the following:


Your site's URL, desired name and shortname (unique ID). You will need to
specify this site ID (shortname) later in the Blog module settings to enable
commenting.



Comments moderator's username, password, and e-mail address. You will
receive a confirmation message to this e-mail address, so be sure to specify a
valid address.

8. Click Continue.
9. Specify your language and other settings, and click Continue.
10. On the last step of the registration form, you do no need to do anything.
Just log out of the Disqus site.
11. Check your e-mail for the confirmation message from Disqus. In this
message, click a link to verify your address.
12. Return to the browser window where you have the Builder editor with
the Blog module properties opened.
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13. In the box titled Apply here the website ID (shortname) received during registration,
type or paste your site ID that you specified during registration with
Disqus on the step 7.
14. Click Apply.
15. Click OK.
Now your blog can accept comments from visitors and you can make the first post.

 To add a blog post:
1. Go to the website page containing a blog module.
2. Click the link Click here to add a new blog post (might also appear as New Post
Title).
3. Type the post title and content.
If you want to change the date of posting, click within the field Posted dd.mm.yy and
then select a date from the calendar.
If your post is lengthy and contains numerous text blocks, images, and embedded
videos, you might want to show only a portion (beginning of the post) to site visitors
in your blog's main page. To do this, while editing a blog post, move the divider
element (containing the line -------- Drag this above modules that should not appear in the
list of posts --------) to the desired area.

4. Click OK.
5. If you want to view, edit, or remove a concise description of the page
that will be displayed on search engines results pages and the
keywords by which the page will be found by search engines, click in a
blank area to the right of the post title, and then click the SEO Settings
tab.
Note: Post link name is a required field. Meta description and Meta keywords are
optional fields. If you specify keywords for a page, they should be separated by
commas without white spaces.

6. To return to the blog's main page, click the Back link below the post you
have just created.

 To remove a blog post:
1. Go to the website page containing a blog module.
2. Place the mouse pointer over the post title and click Remove.
3. Click Yes to confirm removal.

 To edit a blog post:
1. Go to the website page containing a blog module.
2. Click the post title.
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3. Make the required changes and click OK.

 To remove a blog with all posted content:
1. Go to the website page containing a blog module.
2. Place the mouse pointer over the link Click here to add a new blog post and
click Remove.
3. Click Yes to confirm removal.
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Commenting
If you want to let your site visitors leave comments on webpages, you need to insert
the Commenting module into those webpages.
The commenting functionality is powered by Disqus, a third-party service that stores
and processes all comments. Before your visitors can leave comments, you need to
register an account with Disqus and then specify a site ID in the Commenting module
settings.
You can insert several Commenting modules into a single website. Because all
Commenting modules on the site will use the same site ID, you will need to specify the
site ID in module settings only once, when inserting the first Commenting module.

 To add commenting functions to a webpage:
1. Go to the Modules tab, select Commenting, and drag the module to the
page.
2. If you have not registered an account with Disqus yet, click the Register
button. A registration form will open in a new browser window or tab.
3. Specify the following:


Your site's URL, desired name and shortname (unique ID). You will need to
specify this site ID (shortname) later in the Commenting module settings to
enable commenting.



Comments moderator's username, password, and e-mail address. You will
receive a confirmation message to this e-mail address, so be sure to specify a
valid address.

4. Click Continue.
5. Specify your language and other settings, and click Continue.
6. On the last step of the registration form, you do no need to do anything.
Just log out of the Disqus site.
7. Check your e-mail for the confirmation message from Disqus. In this
message, click a link to verify your address.
8. Return to the browser window where you have the Builder editor with
the Commenting module properties opened.
9. In the box titled Apply here the website ID (shortname) received during registration,
type or paste your site ID that you specified during registration with
Disqus on the step 3.
10. Click Apply.
11. Click OK.
Now you can publish your website to the hosting account and start receiving comments
from your visitors.
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In addition to adding and viewing comments, you can do the following:


Edit comments.



Delete comments.



Mark comments as spam.



Ban users (by e-mail and IP addresses) from posting comments on your site.

 To moderate comments:
1. Log in to Disqus as the site administrator. You can do this in either of
the following ways:


Visit the Disqus site at www.disqus.com and log in there.



In the Builder editor, go to the page where you have the Commenting module
and click inside the Add New Comment field. Click the Post as button, click the
Disqus link in the left navigation pane, type your username and password, and
click Login.

2. After you are logged in to Disqus, you can moderate comments in either
of the following ways:


On the Disqus site, use the items in the Dashboard and Admin areas.



In the Builder editor or on the published site, go to the page where you have the
Commenting module, place the mouse pointer over the comment you want to
moderate, and use the Moderate link that will appear next to the comment.

Alternately, you can moderate comments by using links in the notification messages
that Disqus sends you when someone leaves a comment on your site.

 To remove commenting functions from a webpage:
1. In the Builder editor, go to the website page containing the Commenting
module.
2. Place the mouse pointer over the Add New Comment field and click
Remove.
3. Click Yes to confirm removal.
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Documents and Other Downloadable Files
The editor now provides a convenient control panel for working with files under your
hosting account. You can upload your documents, images, and other files in various
formats to the editor (on the Documents tab), and then insert links to them into your
website pages. Or, you can just keep them on your hosting account for your own
needs.

 To upload a file to the hosting account:
1. Go to the Documents tab.
2. Click Upload.
3. Select the file and click Open.
Now, to let your site visitors download this file, you can insert a link to it into a
webpage.

 To insert a link to file:
1. Select the text that you want to make a link.
2. On the Text & Images module's toolbar, click the icon
3. Select the option A document on this site.
4. Select your file and click OK.

 To remove a file from the hosting account:
1. Go to the Documents tab.
2. Select the file and click Remove.
3. Confirm removal and click OK.

.
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Buttons for Sharing on Social Networks
If you want to let your visitors easily share your content on social networks or online
bookmarking services, you can insert a toolbar with buttons for sharing on Facebook,
Twitter, Myspace, and other popular services.

 To add the Share on Social Media toolbar to a webpage:
1. Go to the Modules tab, select Social Sharing, and drag the module to the
page.
2. Select the appearance of the toolbar.
3. If you want to modify the list of social networks and sharing services
shown on the toolbar, place the mouse pointer over the icon [+] and
click the Settings link.
The changes you make to the list of services will be visible after you publish the
site.

4. Click OK.
Note: When someone shares your content on Twitter by using the Tweet button, the
counter of tweets is not increased immediately. It can take several hours for the
counter to update.

 To remove the Social Media toolbar:
Place the mouse pointer over the toolbar and click Remove.

Site Search
If you want to let your visitors search for information on your website, you can add a
search bar to the site. After inserting the search bar into a webpage, it is automatically
added to all pages of the site.
By default, the search bar is configured to use the Google search engine. If you want to
use another search engine, you can obtain the search script code and insert it into the
Search module.

 To add a search bar to the site:
1. Go to the Modules tab, select Search, and drag the module to the page.
2. Do any of the following:


If you want to use the search service provided by Google, leave the Google
option selected.



If you want to use another search engine, select Other and paste the code that
you obtained from that service.

Editing a Website

31

Make sure that the code you insert is correct, as Builder does not validate it.

3. Click OK.
The search bar will appear on your site after publishing.

 To remove a search bar:
Place the mouse pointer over the search bar and click Remove.

Online Store
If you want to sell products or services through your site, you can use the Online Store
and Shopping Cart modules to add a fully functional online store to the site. You can add
only one store per site.
The store functionality is provided by Ecwid - a third-party SaaS solutions provider that
securely stores and processes all your data, including product catalogs with images,
orders, and customers' payments.

 To add an online store to your site:
1. Go to the Modules tab, select Online Store, and drag the module to the
page.
2. Create an account at Ecwid if you do not have it yet, or specify an ID of
an existing store if you already have a store at Ecwid and want to show
it on your site.
If you do not have an account at Ecwid yet, do the following:

a. In module settings, on the General tab, select the option Register
with Ecwid.
b. Type your name, e-mail address, and password. You will use
the e-mail address and password to sign in to Ecwid and
manage your store.
c. Click Send. A confirmation message from Ecwid will be sent to
your e-mail address. You will need to confirm that you own this
e-mail address within three days. Otherwise, the online store
will be deactivated.
If you already have an account at Ecwid, select the option Enter an ID of an existing
shop, specify the store ID, and click Apply.

3. (Optional step.) If you want to let your customers add items to the cart
by dragging them to a shopping bag icon, go to the Modules tab, select
the Shopping Cart module, and drag it to the page.
Note that the shopping bag icon will be inserted into all pages of your site. If you do
not want that, then do not use the Shopping Cart module. Your customers will still be
able to add items to the cart and proceed to checkout by using the Shopping Bag link
that appears at the top of the product catalog area.
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4. (Optional step.) If you want to change the appearance of the product
catalog, in module settings, go to the View tab.
5. To set up your store, fill the product catalog with items, and remove the
default fruit and vegetable items added by Ecwid, click the Manage link
on the module's toolbar.
The Ecwid control panel will open in a new browser window or tab.

6. After you have finished setting up the store in the Ecwid control panel,
return to the Builder editor and click the Reload link on the Online Store
module's toolbar.
You must use the Reload link to synchronize the content of your online store with
online store at Ecwid.

7. Click OK to finish setting up the store.

 To manage a store:
Place the mouse pointer over the product catalog and click Manage. The Ecwid control
panel will open in a new browser window or tab.

 To remove a store:
Place the mouse pointer over the product catalog and click Remove.

Custom Scripts
You can insert custom scripts written in PHP, JavaScript, or VBScript to any page of
your website.

 To insert a script into a webpage:
1. Go to the Modules tab, select Script, and drag the module to the page.
2. Paste the code into the input field.
For PHP, use the opening tag <?php. Make sure the code you insert into this field
is correct, as Builder does not validate it.

3. Click OK.
Your code will be active only on the published website.

 To remove a script:
Place the mouse pointer over the script block and click Remove.
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Advertisement
If you are participating in banner exchange or other online advertising programs, you
might want to add an advertisement block to your site. After inserting the block to a
webpage, it will be automatically added to all pages of your site.

 To add an advertisement block:
1. Go to the Modules tab, select Advertisement, and drag the module to the
page.
2. Paste the code provided by your advertising vendor into the input field.
Make sure that the code you insert into this field is correct, as Builder does not
validate it. With some advertising vendors, you will need to validate your account
first.

3. Click OK.
Advertisements will appear on your website after publishing.

 To remove an advertising block:
Place the mouse pointer over the block and click Remove.

Settings and Tools for Webmasters
This section describes how to do the following:


Change website name, description, and keywords.



Upload a site icon (favicon) for your website.



Make your website more visible in search results and embed various search engine
services.



Prevent some pages or areas of your website from being indexed by search
engines and shown in search results.

 To edit your website name, description, and keywords:
1. Go to the Settings tab > Basic tab.
2. Specify your website name that your visitors will see as the title of their
browser window when they visit your website.
3. To show both your website name and current page name in the browser
title window and to increase your website recognition in search engine
results, select the Add website name to page titles checkbox.
4. Add short description (up to 255 symbols) of your website.
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This description will be used as a default description for new pages. It will be shown
by search engines when people see your website in search results.

5. Provide a list of keywords that describe your website (10-15 keywords
are recommended).
These keywords will be used as default keywords for new pages. Keywords are
analyzed by search engines and used for displaying your website when people
search for these keywords.

6. Click OK to save changes.
Favicon is a small icon displayed in the browser’s address bar when you visit a
website, and next to the website name in the list of favorite bookmarks. You can create
a favicon using a variety of online tools and then upload your favicon here. All your
website visitors will see this favicon.

 To upload a favicon for your website:
1. Go to the Settings tab > Basic tab.
2. Click Browse and select the location of the favicon to upload. The
favicon will be uploaded.
3. Click OK to save changes.

 To remove a favicon from your website:
1. Go to the Settings tab > Basic tab.
2. Click Remove in the Favicon section. The favicon will be removed.
3. Click OK to save changes.
Most search engines require you to verify website ownership when you register your
website or sign up for webmaster assistance services. Verification is typically done by
uploading or creating a file with specific file name.

 To verify website ownership:
1. Go to the Settings tab > Advanced tab.
2. Provide the verification file:


If you know the name of verification file requested by a search engine, provide
the verification file name in the Create verification file field and click OK. Builder will
create it in the correct place.



If you have already downloaded your verification file from a search engine,
upload the verification file to the Upload verification file field and click OK.

3. After the verification file is created or uploaded and your website is
published, confirm your ownership on the search engine website.
4. Click OK to save changes.
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 To edit the HTML <head> section of your website (for example, to add
ownership verification meta code):
1. Go to the Settings tab of the Builder's main menu, then go to the Advanced
subtab.
2. Click Edit Metadata.
3. Insert the code into the provided field and click Add.
Note: Only valid HTML tags permitted for <head> section by HTML standards are
supported. Metadata changes will be available only after you publish your website.

4. Click OK to save changes.
Google Analytics is a tool that allows you to learn more information about your visitors.
After you register in Google Analytics and acquire the required code, you can embed
Google Analytics on your website.

 To embed Google Analytics:
1. Register in Google Analytics and acquire the code.
2. Go to the Settings tab > Advanced tab.
3. Click Embed Google Analytics.
4. Insert the code you have received from Google Analytics to the
provided field and click Add.
Note: Google Analytics will start working only after you publish your website.

5. Click OK to save changes.
Some search engines will ask you to provide your sitemap for analysis and optimization
purposes. You can download your sitemap from the Builder editor.

 To download your website sitemap:
1. Go to the Settings tab > Advanced tab.
2. Click Download Sitemap.
3. Click OK to start downloading the sitemap.xml file.
To prevent search engines from indexing some pages of your website, you can add the
appropriate directives into the robots.txt file. This file is stored on the hosting account to
which your site is published.

 To prevent search engines from indexing some areas of your website:
1. Go to the Settings tab > Advanced tab.
2. Click the link Edit robots.txt.

36

Editing a Website

3. Type your directives into the input field. Place each directive on a new
line.
For example, to prevent all search engine robots and crawlers from indexing the
contents of the directory /private and the file /my_secret.html on your
hosting account, add the following lines:
User-agent: *
Disallow: /private/
Disallow: /my_secret.html
For more information about the robots.txt file and directives you can use, refer to
http://www.robotstxt.org/robotstxt.html.

CHAPTER 5

Saving and Loading Copies of a Website
While working on the content and design of a website, you can save several copies of
each site to the server and restore sites from the saved copies (also referred to as
snapshots). Saving site copies can be useful in the following cases:


You want to prepare several versions of the same website, so that you could later
load them for review, choose the best designed or the most appropriate version,
and publish it to the Internet.



You want to make significant changes or experiment on the site design or content,
and be sure that you can safely undo the changes, should anything go wrong.

Note: Pictures from the Image Gallery modules are not saved in snapshots. Images are
stored on your hosting account or Picasa Web Albums (if you use that option).

 To save the current design and content of a site:
1. In the Builder editor's main menu, click the icon
option.

next to the Save

Note: If you click Save, a quick-save site copy will be saved under the name autosaved snapshot. You will be able to restore a site from this copy later, by clicking
Revert in the main menu.

2. In the list that opens, select a free saving slot, type a name for the
backup copy, and click Save.

 To restore a site from a saved copy:
1. In the Builder editor's main menu, click the icon
option.

next to the Revert

Note: If you click Revert, a site will be restored from the quick-save copy that was
made the last time when you clicked Save.

2. In the list that opens, select a site copy and click Load.
3. Click Yes to confirm restoring.

 To download a site copy:
1. In the Builder editor's main menu, click the icon
option.

next to the Save

2. Locate the copy that you want to download and click the
icon.

(Download)
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3. Select the directory on your computer where you want to save the file
and click OK.

 To upload a site copy:
1. In the Builder editor's main menu, click the icon
option.
2. Click the
it.

next to the Revert

(Upload) icon next to the slot to which you want to upload

3. Browse to the site snapshot file in the SSB format and select it.
4. If you want to restore a site from the uploaded snapshot, select it and
click Load.

 To remove a site copy:
1. In the Builder editor's main menu, click the icon
option.

next to the Save

2. Locate the site copy that you want to remove and click the
corresponding (Remove) icon.

CHAPTER 6

Publishing a Website to the Internet
When your website design and content are ready to be published to the Internet, click
Publish in the top right corner of the main menu. Builder will publish your website
automatically to the location specified by your hosting provider.

CHAPTER 7

Publishing a Website Copy to Facebook
After publishing a site on the Internet, you can drive more visitors to it by publishing a
site copy to the popular social network site - Facebook (www.facebook.com).
A site copy on Facebook will show most of the content from your site, however, the
following changes will be applied to its design and layout:


Headers, sidebars, and a footer will not be shown.



Navigation menu will be shown only at the top of the site pages.



Page width will be limited to 520 pixels. For pages wider than 520 pixels, a
horizontal scrollbar will be shown.



The font face, size, and color will be changed to comply with the Facebook design,
unless these font properties were specifically selected by the site owner in the
Builder editor.



Image galleries, online store, and links for sharing on social media sites will not be
shown.

 If you want to add a site copy to Facebook, do the following:
1. In the main menu, click the Settings tab > Social Media tab.
2. Leave the checkbox Show a copy of my site on Facebook selected.
3. Click the link Add your site copy to Facebook. Facebook home page opens in
a new browser window or tab.
4. To log in to your Facebook account, type your e-mail address and
password, and click Log In.
5. If you do not have a Facebook page where you want to show a site
copy, create it. To do this, click Create It Now, and follow the onscreen
guidelines. After your page was created, return to the Parallels Web
Presence Builder at Facebook page, which is shown in another browser
window or tab.
6. Click Add Parallels Web Presence Builder Application. This application provides
synchronization between the website on your hosting account and its
copy on Facebook.
7. To confirm that you want to add the application to your page, click Add
Parallels Web Presence Builder.
Now your site copy was added. To see it, click the Website link in the Facebook
navigation pane on your left.
Whenever you make changes to your site and republish it through the Builder editor,
your site copy on Facebook will be updated accordingly.
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 To remove a site copy from Facebook, do the following:
1. In the Builder editor's main menu, click the Settings tab > Social Media tab.
2. Clear the checkbox Show a copy of my site on Facebook.
3. Click Yes to confirm.
4. Go to your Facebook page and remove the Parallels Web Presence
Builder application from there.

CHAPTER 8

Deleting a Website
When you delete a site from Builder editor, only the current site draft opened in the
editor and saved site copies (snapshots) are removed. The site copy published to your
hosting account is not removed.

 To delete a current site copy from the editor:
In the Builder editor's main menu, select More > Remove Site.

